Page 1 of 1

Android Eclipse SDK Help

Posted: Fri Mar 28, 2014 3:12 am UTC
by SurgicalSteel
Trying to get set up to do some Android development and was hoping one of you could help me.The development environment is tripping me up. Whenever I would try to run the project this error would popup
[ddms] Failed to initialize Monitor Thread: Unable to establish loopback connection
I updated my SDK through the SDK manager, and now when I run the Eclipse ADT, as soon as the workspace loads I get this error
This Android SDK requires Android Developer Toolkit version 22.6.2 or above.
Current version is 22.3.0v20130242005-887826.
Please update ADT to the latest version.
When I try to update the ADT I get an error that says
Some sites could not be found. See the error log for more detail.
The details button on the error shows
Some sites could not be found. See the error log for more detail.
Unable to read repository at http://dl-ssl.google.com/android/eclipse/content.xml.
Unrecognized Windows Sockets error: 87: create
Unable to read repository at http://download.eclipse.org/eclipse/upd ... ontent.xml.
Unrecognized Windows Sockets error: 87: create
Unable to read repository at http://download.eclipse.org/releases/juno/content.xml.
Unrecognized Windows Sockets error: 87: create


I've tried everything I could find on the internet. Disabling IPv6, disabling the Toredo Tunneling Interface, killing and restarting adb.exe dozens of times, changing the android.ini file to set preferIPv4 to true, etc. Any help would be great. Thanks.