Page 1 of 1

Firefox issue on annotations

Posted: Tue Nov 29, 2016 10:13 am UTC
by St4rgaz3r
So, hi everyone =P

I'm writing this since I'm having an odd issue with Firefox (50.0), and every time I open a "what if" article it automatically opens all the annotations on the page, covering the main text and making it quite difficult to read.. It has been doing this thing for a little while now but I can't tell why, and if I use Chrome I have no problem.

Any suggestion on how to fix it?

Re: Firefox issue on annotations

Posted: Tue Nov 29, 2016 1:21 pm UTC
by Flumble
Sounds like you have javascript disabled on the page. (annotations are visible by default and they're hidden with some javascript code when loading the page)

Re: Firefox issue on annotations

Posted: Mon Dec 05, 2016 7:05 pm UTC
by St4rgaz3r
Ah... thank you.
It seems that java was blocked due to some vulnerability and stopped working on its own. Even after updating and setting on "always active" though it still seems to be disabled.. am i forgetting something?

Re: Firefox issue on annotations

Posted: Mon Dec 05, 2016 8:26 pm UTC
by timrem
Java is not Javascript, Javascript is not Java. I can't actually find a way to natively, wholesale block Javascript in Firefox 50, but you may have an Add-on such as Ghostery or NoScript that is blocking Javascript on What-If.

Re: Firefox issue on annotations

Posted: Mon Dec 05, 2016 8:26 pm UTC
by Flumble
java is not javascript (one is using a plugin container and may be disabled by the browser because of security vulnerabilities, the other is a deeply ingrained part of websites and browsers nowadays; ingrained as in: even clicking a smiley to insert it into your forum post uses javascript)

So my guess would be that you have some extension that is blocking javascript, such as noscript, ghostery, adblock, or you have somehow disabled javascript entirely/your browser doesn't support javascript. (the latter is really improbable though, because half of the websites you're visiting wouldn't even work decently without javascript)

[edit]darn, 40 seconds late

Re: Firefox issue on annotations

Posted: Wed Dec 07, 2016 3:31 pm UTC
by St4rgaz3r
Yea, it actually was adblock =P
not sure if it blocked scripts because of something I did or it's just default, anyway turning it off solved the issue. And also an issue I had on another site that I couldn't figure out.

Thank you!